My FUDforum

Home »  » DeviceMaster RTS, Pro and Serial Hub » DevicemasterRTS RM -Unknown IP, cannot connect
DevicemasterRTS RM -Unknown IP, cannot connect [message #1074] Thu, 15 November 2018 14:55 Go to next message
BobF is currently offline  BobF
Messages: 10
Registered: October 2018
Location: Grand Forks, ND
I have a 32Port RTS S/N 9456-000221.
I have MAC address on the sticker underneath, however this unit has been on a shelf for a while. At one time it was used in a substation network and there is a note on it that says you cannot connect to it. The IP address that is set internally could be just about anything as we have dozens of small networks at different substations. I am trying to connect to the web browser but obviously cannot.

I tried running Wireshark on the ethernet adapter of the laptop I am using. i am connected directly into the Network port of the Devicemaster. I cannot see any IP address of the Devicemaster in wireshark, only the static IP I set my network connection to. So no reply from the Devicemaster even though the LNK/ACT light flashes.

Not sure if there is a way to reset this unit? I looked around on the forum and saw a few suggestions, but none seem to work. My Devicemaster does not have serial ports, so I couldn't do the HyperTerminal test to get to RedBoot.

How do you guys do it if a device gets sent in to be factory reset?

Bob F
Minnkota Power Cooperative
Re: DevicemasterRTS RM -Unknown IP, cannot connect [message #1075 is a reply to message #1074] Thu, 15 November 2018 15:13 Go to previous messageGo to next message
Kurt is currently offline  Kurt
Messages: 290
Registered: July 2016
Location: Minnesota
Power User

Judging from the serial number, you have a really old DeviceMaster.
We have some discovery utilities (beta) that might work for you.


6/7/2018 1:53 PM 7625933 Comtrol-Discovery-Utility-Setup-1.04.exe
9/27/2018 3:44 PM 5127685 DM-Firmware-Updater-Setup-2.02.exe

Your DeviceMaster most likely has RJ45 serial ports. Note that these are not network (ethernet) capable.
This DeviceMaster needs to have a serial connection and you'll need to go into it via console mode. If the above utilities can't find it.
Most likely, you'll need a db9 to RJ45 serial null modem cable to be able to connect.

The newer DeviceMasters have a reset button, this change started with devices coming out this year using the NXP processor.
If all else fails, let me know and I will send you an RMA form where we can look at it and see if it is repairable.


Kurt Rees

Comtrol Corporation
100 Fifth Ave NW
Minneapolis, MN. 55112
Direct +1 763.957.6000 | +1 Fax (763) 957-6001
connect. communicate. control
Re: DevicemasterRTS RM -Unknown IP, cannot connect [message #1076 is a reply to message #1075] Mon, 19 November 2018 13:33 Go to previous messageGo to next message
BobF is currently offline  BobF
Messages: 10
Registered: October 2018
Location: Grand Forks, ND
Well, I tried the utility tools and could not discover the Devicemaster. I pieced together a null modem cable (USB to serial converter, then a Null adapter and finally a DB9 to RJ45 cable). Plugged it into Port 1 of the Devicemaster and Com 3 of my Laptop. Using Baud 57600 in the converter and for WCom2, I still could not get anything to happen in the console window. No RedBoot prompt in my 20 plus attempts. Wish there was some feedback when you do this like text in the console window, a blinking status light on Port 1 of the Devicemaster, etc.

During my attempts the lights on the Devicemaster are as follows: Yellow status light blinks for about 15 sec, (so that means I should have enough time to get it to work). The yellow light on Com 1 glows steady with the RJ45 cable plugged in but no other yellow or green blinks noted.

You can call direct so we can discuss the next step of maybe sending this unit in for repair. Since it is very old I need to decide if the cost is worth it. (My phone number below is obscured a bit so no internet bots find it)


Bob F
Minnkota Power Cooperative
Re: DevicemasterRTS RM -Unknown IP, cannot connect [message #1077 is a reply to message #1076] Mon, 19 November 2018 14:14 Go to previous message
Matt is currently offline  Matt
Messages: 18
Registered: November 2018
Location: Minnesota
Hi Bob,

Most of the information so far does look like there's a decent chance the unit may need repair. Before sending it in, one last thing to check if you haven't already is a loopback test with your USB serial device - just to be 100% certain that the communication at least gets as far as the output of the cable.

Basically, all you'd need is an RJ45 loopback adapter, which can easily be made from a spare Ethernet cable: http://downloads.comtrol.com/contribs/devicemaster/help_file s/cables/build_rj45_loopback_from_an_ethernet_cable.pdf

That loopback adapter would plug into the end of your USB-to-serial -> Null adapter -> DB9-to-RJ45 setup. Once it's attached, you should be able to fire up the WCom2 Test Terminal from PortVision DX and test to see if keyboard input is echoed onscreen.

If that does work, then we know that the DeviceMaster is the cause of the issue. In that case, let us know and we'll create an RMA case for you to explore options.

If that test doesn't work, then we still don't know for certain whether or not the DeviceMaster is at fault; in that case, the communication is being interrupted somewhere earlier.

Please let us know how that goes - thanks!


Matt Mayfield

Comtrol Corporation
100 Fifth Avenue NW
New Brighton, MN 55112
(763) 957-6000
Previous Topic: What does the color of the Status light on a RTS 1-port indicate?
Next Topic: DB9M 4-Port, Can't connect to it by any means
Goto Forum:

Current Time: Wed Jun 23 00:05:34 CDT 2021

Total time taken to generate the page: 0.00955 seconds