FUDforum
My FUDforum

Home »  » DeviceMaster RTS, Pro and Serial Hub » Cant open COM Ports (Cant open COM Ports)
Cant open COM Ports [message #968] Wed, 09 May 2018 07:13 Go to next message
Jsteg3346 is currently offline  Jsteg3346
Messages: 2
Registered: May 2018
Location: Maryland
Junior Member
I have a Devicemaster Pro 8 serial port that is connected to a Dell computer that runs windows 10. When the computer restarts after a Windows 10 update, I receive a COM 3 port error. That particular port is what we use to connect to our Lband router. I check the device manager and the latest drivers are installed and everything looks normal. In order to get the Devicemaster Pro to work properly, I have to go into the Installation wizard for the DeviceMaster and update the drivers. Only after that, can we connect to our devices. So basically, anytime the computer restarts, (not a hard shutdown) the Devicemaster wont connect to our router and we receive the COM Port failure. Only updating the Drivers via the Devicemaster Installation wizard does the problem resolve itself. Is there anything we can do so we don't have to keep updating the driver after every time the computer restarts itself.
Re: Cant open COM Ports [message #969 is a reply to message #968] Wed, 09 May 2018 07:30 Go to previous messageGo to next message
Kurt is currently offline  Kurt
Messages: 290
Registered: July 2016
Location: Minnesota
Power User
Hi Jsteg3346,

This is the first time that I've heard of this behavior.
What version of driver are you using for the DeviceMaster?

What was the Windows Update number? I'd like to see if I can reproduced it hear.

Is it only with Com 3 and all other ports are ok?

Thanks,
Kurt



Kurt Rees
www.comtrol.com
http://forum.comtrol.com/

Comtrol Corporation
100 Fifth Ave NW
Minneapolis, MN. 55112
Direct +1 763.957.6000 | +1 Fax (763) 957-6001
connect. communicate. control
Re: Cant open COM Ports [message #970 is a reply to message #969] Wed, 09 May 2018 07:52 Go to previous messageGo to next message
Jsteg3346 is currently offline  Jsteg3346
Messages: 2
Registered: May 2018
Location: Maryland
Junior Member
Hi Jsteg3346,

This is the first time that I've heard of this behavior.
What version of driver are you using for the DeviceMaster?

What was the Windows Update number? I'd like to see if I can reproduced it hear.

Is it only with Com 3 and all other ports are ok?

Thanks,
Kurt

The version of the driver is 3.2.0.0
Driver date is 10/12/2017

The windows update number is Windows 10, version 1709

Com 3 is the port we use to connect to our L-Band Router. When you check it in the device manager, it shows the comport is operating normally, but when we open up our satellite control program, it says it receives a COM Port 3 error, when the program boots up it connects to all of our satellite receivers and our LBAND router, the LBAND router is connected to COM Port3
Re: Cant open COM Ports [message #971 is a reply to message #970] Wed, 09 May 2018 08:01 Go to previous message
Kurt is currently offline  Kurt
Messages: 290
Registered: July 2016
Location: Minnesota
Power User

Hi Jsteg3346,

I would like for you to do a test when this re-occurs.

1. If the Com Port can't be opened, sometimes its because it is left open or is being used by something else.
Shut down your application using the com port and open Test Terminal to see if it opens the com port.
By doing this test, we can verify if the com port is hung or if the DeviceMaster is a factor.

Once the port is open, do a loopback test to send/receive using test terminal.
This will verify data going through the com port / driver to the DeviceMaster and back again.

Use this document for doing the test as a reference:

http://downloads.comtrol.com/contribs/devicemaster/help_file s/Basic%20DM-serial-troubleshooting.pdf

Thanks,
Kurt


Kurt Rees
www.comtrol.com
http://forum.comtrol.com/

Comtrol Corporation
100 Fifth Ave NW
Minneapolis, MN. 55112
Direct +1 763.957.6000 | +1 Fax (763) 957-6001
connect. communicate. control
Previous Topic: Devicemaster v7.27 compile errors [Fedora Linux]
Next Topic: DeviceMaster RTS 1 port non responsive after reset
Goto Forum:
  


Current Time: Tue Jun 15 21:24:17 CDT 2021

Total time taken to generate the page: 0.00628 seconds