FUDforum
My FUDforum

Home »  » RocketPort Express/Infinity » RocketPort Express lose sporadic a byte on Win10 PC's
RocketPort Express lose sporadic a byte on Win10 PC's [message #1332] Thu, 25 March 2021 07:54 Go to next message
Matthias is currently offline  Matthias
Messages: 4
Registered: March 2021
Junior Member
Hi,
we have problems with a missing Byte in an incoming continuously stream of bytes.
Are there any known issues?


Setup:
Win10 (Version 1909)
RocketPort EXPRESS Octacable DB9M (Part Number: 30128-8)
Driver 5.18.0.0
Driver-Setup:
Polling 1ms
RS232-Setup:
Baudrate 115200
Databits 8
StopBits 1
Parity None

Background:
A sensor is streaming continuously measurement data with MSB-LSB formatting. One sample for the application consist of two bytes.
Our application detects an incorrect MSB/LSB formatting.

What was tested so far:
Driver-Setting with polling 2ms and 10ms.
Verified with an external LogicAnalyser (Saleae) that the sensor is streaming the data in the correct order.
Simultaneously checked with a software RS232-Logger (DeviceMonitoringStudio) that the missing byte is not forwarded to the application by the "RocketPortDriver".
Put the hardware (sensor) to an internal RS232-Port -> No issues!
With Win7 no issues known with that configuration.
With "No-Streaming-Data-Projects" there are no issues known.

Notice:
In the past (Win7) with another vendor, we had the same issue. Solution was in that case a new driver.
Another notice from my side is, that the ReceiveBufferSize of the "RocketPortDriver" could not be set to a higher value (default seems to be 8191 bytes) -> e.g. try to set with IOCT_Serial_Set_Queu_Size to 32784 bytes fails (maybe another problem)


Thanks,
Matthias
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1334 is a reply to message #1332] Thu, 25 March 2021 08:58 Go to previous messageGo to next message
Ed is currently offline  Ed
Messages: 7
Registered: July 2019
Member
Hi Matthias,

Try changing the driver to interrupt mode and a scan rate of 2 ms.

If that doesn't work, you will need to use Comsniff capture the output illustrating the error.

Regards,

Ed Carrizales
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1335 is a reply to message #1334] Tue, 06 April 2021 07:50 Go to previous messageGo to next message
Matthias is currently offline  Matthias
Messages: 4
Registered: March 2021
Junior Member
Hi Ed,
sorry for late answer, but the testsystem on production was only now available for debugging tests.

Changing driver to interrupt mode and a scan rate of 2ms has no positive effect.

Attached a capture of ComSniff from UUT1 on COM9 (RocketPort2)
Failure occurs on testrun 3 -> see record 7227

Background:
On record 7226 MSB/LSB formatting is still correct -> MSB=0xA0 / LSB=0x00
On record 7227 MSB/LSB formatting error -> MSB with 0xA0 is missing!

Setup for this capture:
4 UUTs on Comport 9...12
Driver in Polling-Mode and scan rate 2ms
ComSniff v1.06 https://files.comtrol.com/contribs/utilities/comtrol/ComSniff

Notice:
Capture of UUT 2...4 also available. But ComSniff captured UUT2 and UUT3 not complete. Capture of UUT 4 again is complete.
If you need that, please let me know.


Is it possible for you to simulate this situation with a similar setup?


Thanks,
Matthias
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1336 is a reply to message #1332] Tue, 06 April 2021 10:24 Go to previous messageGo to next message
Ed is currently offline  Ed
Messages: 7
Registered: July 2019
Member

Hi Matthias,

Have you updated the drivers to the latest revision v5.18?

https://downloads.comtrol.com/express/

Once I hear back from you on the version, I will send the information you have given me to engineering.

Regards,
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1337 is a reply to message #1336] Wed, 07 April 2021 03:37 Go to previous messageGo to next message
Matthias is currently offline  Matthias
Messages: 4
Registered: March 2021
Junior Member
Hi Ed,

latest version v5.18 of driver is used. See also attachment.

Ok, I am waiting for a response from your side.

Thanks,
Matthias
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1338 is a reply to message #1337] Wed, 07 April 2021 08:25 Go to previous messageGo to next message
Ed is currently offline  Ed
Messages: 7
Registered: July 2019
Member
Hi Matthias,

Engineering has suggested:

One other thing to consider is if the driver is configured for polling or interrupt mode.

I would have the customer configure for interrupt mode and if that doesn't work decrease the scan rate to 5ms.
Re: RocketPort Express lose sporadic a byte on Win10 PC's [message #1342 is a reply to message #1338] Thu, 08 April 2021 01:48 Go to previous message
Matthias is currently offline  Matthias
Messages: 4
Registered: March 2021
Junior Member
Hi Ed,
in our lab I have a simulated it with folling setups again:

Setup1
Driver Mode: Interrupts
Scan rate: 2ms
Setup2
Driver Mode: Interrupts
Scan rate: 4ms (5ms not possible, see attachment)

In both cases, no significant positive effect.
So, I think a test on production-line not necessary.

Notice:
We have two systems.
One in production with one RocketPort EXPRESS Octacable DB9M
One in our lab with two RocketPort EXPRESS (Octacable DB9M + Quadcable DB9M)
Both PC's with same Image (and of course hardware)

One other remark:
Yesterday I've tried on production-line a test with "Driver Mode: Interrupts" / "Scan rate: 2ms"
~1500 runs with 5 errors BUT also in some runs our application freeze, so fallback to "Driver Mode: Polling" / "Scan rate: 1ms"


Regards,
Matthias
Previous Topic: RocketPort Infinity Interface Cable
Next Topic: RocketPort Express 32 port 30138-7 and RackMount 30060-1 with fuzzy LED
Goto Forum:
  


Current Time: Wed Apr 21 03:31:01 CDT 2021

Total time taken to generate the page: 0.00947 seconds